翻譯成 Translate to... English | 繁體中文 | 简体中文

解決 Firefox 升級後,反而不能使用擴充套件的問題

Firefox 瀏覽器升級到 42 版本,原本的擴充套件出現反而不能使用的問題。在 Firefox 設定頁面 about:config,將 xpinstall.signatures.required 的值設定為 false ,再重新啟動 Firefox 即可解決。

[更新 2017/5/8]
Firefox 文件: 「在Firefox ESR 45 版,以及 Firefox 開發者版本Nightly 版中,在 Firefox 設定編輯器about:config頁面)將xpinstall.signatures.required 修改成 false 來停用強制簽署的功能。在其他特殊版的 Firefox 也允許覆寫此設定。更多資訊,請參閱 MozillaWiki 文章 Add-ons/Extension Signing。」


解決方式的步驟說明:
1. 選單: 工具 --> 附加元件 --> 擴充套件。可以看到很多擴充套件,被標示「無法驗證 (擴充套件名稱) 於 Firefox 使用,已被停用。」



2. 網址列輸入 about:config ,再點選「我發誓,我一定會小心的!」按鈕。



3. 搜尋 xpinstall.signatures.required ,在該偏好設定名稱上,按滑鼠右鍵出現選單,點選「切換」



4. 將 xpinstall.signatures.required 的值設定為 false



5. 回到擴充套件清單,有些擴充套件已經恢復可用。部分擴充套件,則還需要重新啟動 Firefox 才能啟用。



[更新 2016/5/16]
Firefox 網站公告「Firefox 47 beta 測試版與正式發行版本中,將會強制需要附加元件簽章」。如果擴充套件升級後無法通過簽章,但是仍然需要使用這個擴充套件,則可以降級 Firefox,安裝舊版 Firefox 繞過這個問題。


參考資料




留言

  1. 值要設定為false才能使用沒驗證的附加元件,圖片上也是表示這樣。

    回覆刪除

張貼留言

facebook page