翻譯成 Translate to... English | 繁體中文 | 简体中文

Solve wubi installer's pyrun.exe says "no disk" (Wubi 10.10)



When I executed the wubi installer, pyrun.exe says "drive E: no disk". Because I have more than one CD-ROM (included virtual CD-ROM). I change the drive letter of my CD-ROM to pass the problem.


Condition:
1. I mounted the Ubuntu 10.10 CD image file (ubuntu-10.10-desktop-amd64.iso) into drive G by virtual CD-ROM software: DAEMON Tools lite (download)

2. When I executed the wubi installer, pyrun.exe says "drive E: no disk" (drive E is my another CD-ROM)

Image: pyrun.exe says "drive E: no disk" ("pyrun.exe - 沒有磁片" in Chinese)

3. My options were Cancel, Try Again, and Continue and the "X" to close the window

4. No matter what option I clicked, the error message just pops up.


Solution:
1. I press the keys Ctrl + Alt + Delete to open the Windows Task Manager.

2. Find the process "pyrun.exe", and "End Process". The annoying pyrun.exe error window will not show up.

3. Press the Start. Enter the Control Panel -> Performance and Maintenance -> Administrative Tools -> Computer Management -> Disk Management. (More details on How to change drive letter assignments in Windows XP / 如何在 Windows XP 中變更磁碟機代號的指派)

4. I change the drive letter of my first CD-ROM from drive E to drive Z.

5. Go to the virtual CD-ROM software: DAEMON Tools lite, and add a new virtual CD-ROM. It should be applied the drive letter: drive E.

6. I mount the Ubuntu 10.10 CD image file into new drive E.

7. Execute the wubi installer. It worked!


further reading:
* Bug #365881 in Ubuntu: “wubi installer's pyrun.exe says "no disk"”

留言

facebook page